Increased Error Rates and Latencies in Mobile Verify us-east-1 production and sandbox platforms

Incident Report for Mitek Systems Status Page

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:10 UTC

Monitoring

Between 12:10 AM and 2:30 AM PDT, our platform experienced increased error rates and latency due to an incident affecting our cloud provider’s US-EAST-1 region.

As our cloud provider implemented mitigations, services gradually recovered. By approximately 2:30 AM PDT, most functionality had returned to normal, and full recovery was confirmed shortly thereafter.

We continue to monitor system performance closely and are working with our cloud provider to ensure continued stability.
Posted Oct 20, 2025 - 10:11 UTC
This incident affected: Mobile Verify - US-EAST-1 (Mobile Verify Auto, Mobile Verify Face Compare, Mobile Verify Agent Assist).