P1 - Face Comparison Experiencing Issues

Incident Report for Mitek Systems Status Page

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 01:20 UTC

Monitoring

Fix implemented. Systems showing successful transactions. Monitoring for continued success.
Posted Apr 01, 2025 - 01:06 UTC

Identified

We have identified the root cause. The fix is being implemented.
Posted Apr 01, 2025 - 00:42 UTC

Investigating

We are investigating an issue with Face Comparison Requests.
Posted Apr 01, 2025 - 00:20 UTC
This incident affected: Mobile Verify - CA-CENTRAL-1 (Mobile Verify Face Compare), Mobile Verify - US-WEST-1 (Mobile Verify Face Compare), Mobile Verify - US-EAST-1 (Mobile Verify Face Compare), and Mobile Verify - EU-WEST-1 (Mobile Verify Face Compare).